Author Topic: Correct agent status not showed on agent's page  (Read 4055 times)

arturohg

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
    • View Profile
Correct agent status not showed on agent's page
« on: June 09, 2009, 08:14:40 »
I have installed QM 1.5.3 with asterisk 1.2.
Everything seems to working fine except the agent status on the agent page.
It states: Agent/156: Agent is currently logged off

When I click on the logon button it shows this:
 
Quote
-- Attempting call on Local/20@queuemetrics/n for 10@queuemetrics:1 (Retry 1)
    -- Executing Answer("Local/20@queuemetrics-b0ca,2", "") in new stack
       > Channel Local/20@queuemetrics-b0ca,1 was answered.
    -- Executing Answer("Local/20@queuemetrics-b0ca,1", "") in new stack
    -- Executing Wait("Local/20@queuemetrics-b0ca,1", "10") in new stack
    -- Executing NoOp("Local/20@queuemetrics-b0ca,2", " "QM: Logging on Agent/156 to extension 156@druid-user-telemarketing made by agent/156" ") in new stack
    -- Executing AgentCallbackLogin("Local/20@queuemetrics-b0ca,2", "156||156@druid-user-telemarketing") in new stack
    -- Playing 'agent-loginok' (language 'en')
  == Callback Agent '156' logged in on 156@druid-user-telemarketing
    -- Executing Hangup("Local/20@queuemetrics-b0ca,2", "") in new stack
  == Spawn extension (queuemetrics, 20, 4) exited non-zero on 'Local/20@queuemetrics-b0ca,2'
  == Spawn extension (queuemetrics, 10, 2) exited non-zero on 'Local/20@queuemetrics-b0ca,1'
Jun  9 01:06:36 NOTICE[19828]: pbx_spool.c:279 attempt_thread: Call completed to Local/20@queuemetrics/n

and when I issue the show agents command it lists the agent:
Quote
156          (Pedro) available at '156@druid-user-telemarketing' (musiconhold is 'default')

At this time, the agent is logged on but the web page's agent status remains the same: logged off
Even, when I click on logout, it works fine on the asterisk side but no events are writen to the queue_log file

Thank you


QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Correct agent status not showed on agent's page
« Reply #1 on: June 10, 2009, 08:12:45 »
DO you see anything added to the queue_log file when you log on? Old versions of Asterisk did not do the loggin proper - see e.g. http://queuemetrics.com/faq.jsp#faq-039-dynamic_members_12

arturohg

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
    • View Profile
Re: Correct agent status not showed on agent's page [Solved]
« Reply #2 on: June 11, 2009, 15:22:18 »
I was not writing to the queue_log file.

I fixed with your recommendation.

Thanks

QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Correct agent status not showed on agent's page
« Reply #3 on: June 12, 2009, 14:46:04 »
 ;D