Author Topic: Agents with multiple queues problem  (Read 1032 times)

jonath_ba@hotmail.com

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Agents with multiple queues problem
« on: August 29, 2017, 22:56:04 »
I have a lot of problems with agents receiving calls from different queues once they become available, obviously the agent can only answer one of the calls. How can I fixed this?

I almost sure there is a problem in my config or perhaps a limitation of queuemetrics.

Thanks in advance




mirkox

  • Full Member
  • ***
  • Posts: 231
  • Karma: 4
    • View Profile
Re: Agents with multiple queues problem
« Reply #1 on: August 30, 2017, 08:03:19 »
Hi,
QueueMetrics can't in any way interfere with the call routing of your PBX; probably the problem is due to the setup of your queues (check the ring strategy, make sure you have ringinuse=no in all your queues).


mirkox

  • Full Member
  • ***
  • Posts: 231
  • Karma: 4
    • View Profile
Re: Agents with multiple queues problem
« Reply #2 on: January 08, 2018, 09:55:59 »
Hi, theres nothing to wait, it depends only on your PBX configuration. Check the "Skip Busy Agent" configuration on all your queues.


eaortizn85

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
    • Email
Re: Agents with multiple queues problem
« Reply #3 on: May 09, 2018, 18:07:32 »
I apologize if this is a solved issue, but since I don't see it marked as SOLVED I'd like to contribute with my own experience.

I had the same issue using a softphone (tested Zoiper, X-Lite, 3CX and Micro SIP), Asterisk 11 (using chan_sip module instead of pjsip) and FreePBX 14 on my PBX. As Mirko said, QM has nothing to do with this; it is all about configuration on the PBX side.

The situation was as follows: the agent would receive a cal from Queue 01, however if a call rings in Queue 02 it would start the ringing alert (visual and sound) on the agent screen, of course this is really annoying for the agents, especially if they are logged in different high traffic queues.

We came up with 2 solutions for this:

1. MicroSIP has a parameter that sets the device to busy once he has 1 call (check documentation); along with disabling the alerts for MicroSIP would work. This works but it isn't ideal because the PBX will keep sending ringing alerts and the logs will be filled up with busy responses.

2. In FreePBX, the Skip Busy Agent configuration must be checked for "Yes+ringinuse=no" this will monitor the device status instead and therefore skip the extension device and not send the ring alert. On a side note, despite the ring strategy, I recommend using the Autofill configuration, check the documentation and you will see why.

Hope this help future readers.

eaortizn85

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
    • Email
Re: Agents with multiple queues problem
« Reply #4 on: June 01, 2018, 05:23:12 »
Well our servers have been up for 6 months now, so I believe it works  :)

QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2999
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Agents with multiple queues problem
« Reply #5 on: June 26, 2018, 12:23:45 »
 :)