Author Topic: Wombat and JRE issues  (Read 478 times)

terry_tate

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Wombat and JRE issues
« on: December 09, 2016, 17:17:15 »
We have two systems, one running Elastix 2.4 and one running Elastix 4.  We ran into the following issues on both systems on Mysql 5.6 and MariaDB 5.6.  Running Java 1.6 overnight the dialer will stop and cannot be started again.  Java errors due to connection hibernation, it disconnects from MySQL and will not reconnect.  To fix we updated to Java 1.8 and confirmed the problem was resolved.  On Java 1.8 you cannot schedule callbacks in the recall scheduler.  Ultimately we found that if we run Java 1.7 everything works.  It appears the fix for the recall issue is resolved by updating Tomcat which we did NOT do and it is not available in the repo.  We know we can do it manually but I like to use the repo when possible as we do keep our systems updated.  Right now everything is working but I wanted to post this to make you aware of the issues we had.

Hibernate issue:
Dec 7, 2016 2:51:56 PM org.hibernate.transaction.JDBCTransaction commit
SEVERE: JDBC commit failed
com.mysql.jdbc.exceptions.MySQLNonTransientConnectionException: Connection.close() has already been called. Invalid operation in this state.

Callback issue:
Dec 08, 2016 3:18:40 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet jsp threw exception
org.apache.jasper.JasperException: Unable to compile class for JSP:

An error occurred at line: 1 in the generated java file
The type java.io.ObjectInputStream cannot be resolved. It is indirectly referenced from required .class files

mirkox

  • Loway
  • Full Member
  • *
  • Posts: 225
  • Karma: 3
    • View Profile
Re: Wombat and JRE issues
« Reply #1 on: December 13, 2016, 14:36:58 »
Hi terry,

thanks for your message, we'll look into it.
We know that Java 1.8 is not compatible at the moment; but it is supposed to work perfectly on Java 1.6 so this is quite strange.

Mirko