Author Topic: Proxy Authentication on outbound connection  (Read 583 times)

gogusrl

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Proxy Authentication on outbound connection
« on: August 30, 2016, 14:41:16 »
Hello,

 First of all I'd like to apologize if I say something stupid here, I'm still learning Asterisk.

 My problem is this :

 I have an asterisk based PBX (MobyDick by Pascom) using 2 providers. On one provider Wombat works fine, on the other provider I get "NOTICE[3420][C-0000047d]: chan_sip.c:22872 handle_response_invite: Failed to authenticate on INVITE to '"Anonymous" <sip:anonymous@anonymous.invalid>;tag=as5f6f66ee'" .

 The non-working provider tells me they require on every INVITE Proxy Authentication with username / password.
 Can I set those up (user/password) in Wombat or I'm doing something wrong elsewhere ?

Thank you for your time and help.

mirkox

  • Loway
  • Full Member
  • *
  • Posts: 210
  • Karma: 3
    • View Profile
Re: Proxy Authentication on outbound connection
« Reply #1 on: August 31, 2016, 09:49:14 »
Hi!

WombatDialer doesn't have the possibility to put advanced SIP settings; what we do normally, with FreePBX for example, is to define the trunk on the PBX with all the settings; then from Wombat we define a trunk as Local/NUMBER@from-internal/n   , that lets the PBX route the call correctly; not sure how you do this on mobydick though

Mirko

gogusrl

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Proxy Authentication on outbound connection
« Reply #2 on: August 31, 2016, 12:27:30 »
Hey,

Thanks for the reply. This has solved my problem. The integration guide from MobyDick was telling me to declare the trunk as SIP/mdc_trunk_conf-1/${num}. Changed it to your example and everything works.

Thanks again.