Author Topic: Qloader + Queuemetrics cant loggin agent.  (Read 14029 times)

QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #15 on: January 28, 2013, 12:42:40 »
The config looks correct.
Are you sure that your agents are choosing the right server when logging in?

luiz@tribecapediatrics

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
    • View Profile
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #16 on: January 28, 2013, 15:02:49 »
When the agent goes to login, they have no option to choose the server. It only give the agent the option for their agent number, extension number and the queue they are logging in to.


QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #17 on: January 29, 2013, 11:03:26 »
In cluster mode, the agent's page should display a selector so they can choose where to log in to.

luiz@tribecapediatrics

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
    • View Profile
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #18 on: January 29, 2013, 13:53:40 »
Would you be able to send me a working configuration.properties file? I dont see anywhere on my agent's page where they can select the server.

Thank you

luiz@tribecapediatrics

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
    • View Profile
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #19 on: January 29, 2013, 17:13:22 »
Update: I am able to login to the remote server only if i add the tcp AMI connection setting to the following line.

#callFile spool dir, set to blank for no call files at all or use TCP AMI connection
callfile.dir=

This is not the line under the cluster section. If I leave this line empty I get an error message on queuemetrics and I can't find a way to add both server AMI configuration.


QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #20 on: January 31, 2013, 11:49:00 »
This is weird. I'll open up a bug for this.
Bug #1839
« Last Edit: January 31, 2013, 11:52:56 by QueueMetrics »

luiz@tribecapediatrics

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
    • View Profile
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #21 on: January 31, 2013, 14:54:22 »
Thank you, Do you have a bug tracker page? So I can track the progress in this case. This feature is extremely important for us, and my demo license is about to expire.

QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #22 on: February 04, 2013, 10:39:45 »

Hi Luiz,
we don't verify your issue.
With the following settings:
   
   
Code: [Select]
# This is the default queue log file.
default.queue_log_file=cluster:*


#callFile spool dir, set to blank for no call files at all or use TCP AMI connection
callfile.dir=tcp:admin:amp111@127.0.0.1


# Cluster to poll for RT data
# list of pipe-separated members of the cluster
# if callfilesdir = "", the commands will be sent through the manager API
cluster.servers=aleph|trix

cluster.aleph.manager=tcp:admin:amp111@127.0.0.1
cluster.aleph.queuelog=sql:P001
cluster.aleph.monitored_calls=
cluster.aleph.callfilesdir=
cluster.aleph.audioRpcServer=
cluster.aleph.agentSecurityKey=

cluster.trix.manager=tcp:admin:amp111@127.0.0.1
cluster.trix.queuelog=sql:P002
cluster.trix.monitored_calls=z:/qm_streamcall/server_trix
cluster.trix.callfilesdir=
cluster.trix.audioRpcServer=
cluster.trix.agentSecurityKey=

I get the drop-down server selection. What matters here is the "cluster:*" that tells the agent page to ask for a selector.

We are marking bug #1839 as "not verified" for now, pending further input.

QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #23 on: February 04, 2013, 10:40:39 »
Thank you, Do you have a bug tracker page? So I can track the progress in this case. This feature is extremely important for us, and my demo license is about to expire.

Please ask for a renewal to our support line. We want you to be happy with the product.


luiz@tribecapediatrics

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
    • View Profile
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #24 on: February 06, 2013, 14:20:10 »
Solved.

Thank you I was able to get it to work. Under this line default.queue_log_file=cluster:*, I had wrong information there, I had default.queue_log_file=sql:cluster:*

QueueMetrics

  • Loway
  • Hero Member
  • *
  • Posts: 2993
  • Karma: 39
    • View Profile
    • QueueMetrics
Re: Qloader + Queuemetrics cant loggin agent.
« Reply #25 on: May 16, 2013, 08:38:27 »
That was a hard find :)