QueueMetrics forum

QueueMetrics => Installing through QueueMetrics Espresso => Topic started by: palillo on October 23, 2016, 03:11:07

Title: Can't log into queues sip registry is empty.
Post by: palillo on October 23, 2016, 03:11:07
Hi,

I have just installed a Queuemetrics Espresso version over a clean installation of Elastix 2.5.0 64-bits distribution which comes with FreePBX 2.11 and Asterisk 11.21.0

All went ok, I was able to create extensions, queues, etc according to instructions.

When I log into the agent web portal and open the Agent Logon window, then enter the current Operator extension and click on the queue and the ">" button to log into the Queue, it takes a long time and when timeout, the agent is not being logged on into the queue.

I googled arround, check all parameters, etc and then, I tcpdumped and wiresharked the AMI session to see what is happening.  At first, I thought the AMI was not being logged on successfully but then, I follow all the AMI commands when login into the queue and found that 'sip show registry" is empty.

However, sip show peers show all extensiones logged in correctly and I am able to receive/place calls without any issue.

Agent can't log into the queue via the "Agent Logon" windows because there is no SIP registry entry.

I tried to add registry = yes into the sip.conf with no result.

Any help is greatly appreciated.

Regards


Title: Re: Can't log into queues sip registry is empty.
Post by: mirkox on October 24, 2016, 08:58:54
Hi Palillo,

are you sure your PBX is logging the queue_log file?

Mirko